7

Bluetooth LE (BLE) Feedback

Today's Zwift Mobile Link 1.4 release for iOS introduces the ability to use your Bluetooth LE (BLE) fitness peripherals with Zwift. 

 

BLE support is finally out of beta, and supports heart-rate monitors, cadence and speed sensors, power-meters and all major brands of smart trainers which broadcast BLE.

 

Bluetooth also now works natively with Apple computers. If you're running the OSX version of Zwift you should now have a "gear" icon on your pairing screen title bar. Clicking it allows you to toggle between finding Bluetooth devices via Zwift Mobile Link running on your phone, or via the built-in bluetooth in your computer. Give it a try, and please let us know if you have issues. NOTE: We are still researching how, or if, we can bring this feature to Windows laptops.

 

Click here for instructions on how to get started. We look forward to your feedback!

 

204 comments

  • Avatar
    Alarik Myrin Official comment

    We are testing a new game build now that will hopefully address this.  Hope to have it released soon.

  • 0
    Avatar
    Syed Omar

    I tried to make this work just now. My equipment;

    1. Macbook Pro (OSX El Capitan)
    2. iPhone 6
    3. Bontrager DuoTrap Bluetooth ANT+ Speed & Cadence Sensor

    Both running on the same WIFI network.

    I have no problems connecting my sensor to my phone and appear correctly on my mac. The numbers (speed & cadence) appears to be showing correctly on my mac, but only cadence reading shows on my phone.

     

    Speed & cadence reading detected on my mac.


    Only cadence reading appears on the app.

    So, I thought since both readings detected perfectly on my mac, this will work even though my app only detect one reading. Sadly, no, it does not work. It only shows cadence reading when I'm pedalling and the rider does not move at all. It just stays there while the upper left corner shows the cadence reading.

    I can't thank you guys enough for introducing this feature but I hope you can troubleshoot this issue.

    Cheers,

    Syed

  • 0
    Avatar
    Bing Quezon (Agila Cycling)

    This is great news!  Thank you for supporting BLE.  However, after following your instructions, it seems it doesn't work.  I was able to pair all my BLE devices (HRM, Cadence, and Speed + Trainer).  I have the CycleOps Powerbeam Pro but since that's not supported yet, I chose the Fluid model.  After entering the Beta code and pairing my devices, when I start to pedal the rider doesn't move. It just sits there.  I do see my heartrate and cadence move but the MPH doesn't. In the pairing devices section, I see the MPH go up when I'm pedaling but not on the game itself.  Let me know if I missed a step.  It seems to be the same issue as posted by Syed.

    My setup is.

    1.  Mac OSX Yosemite

    2.  iPhone 6 (iOS 9.1)

    3.  Wahoo HRM ANT+/BLE

    4.  Jarv Speed/Cadence BLE

    5.  Cycleops Powerbeam Pro BLE

  • 0
    Avatar
    Brian Gorby

    Hey Syed / Bing - thanks for the heads up, and sorry to hear about the issues. We're investigating the issue and hope to have an update soon.

    Bing, as Jon mentioned in your other post, pairing the Powerbeam Pro as a simple power meter (and not using a speed + classic trainer combination) should work (and would work better than just speed + classic). 

  • 0
    Avatar
    Peter Lin

    I was able to use the BLE beta to pair with wahoo Run, Tickr and speed/cadence sensor. When I tried to pair with Stages power, it caused Zwift to crash. I see errors in the log. I can email the logs if that helps

    thanks for all the great progress

     

    peter

  • 0
    Avatar
    Brian Gorby

    Hi Peter,

    Can you open a ticket here? http://bit.ly/ZwiftSupport

    Just include that it's for me, and I'll grab the log files (from the app and the game) from you.

    Thanks!

     

     

  • 0
    Avatar
    James Allanson

    We tried to get my wife's bike up and running on Zwift tonight (she's got all BTLE sensors) and it didn't work.  Here is her setup:

    1. Windows 7
    2. iPad Mini
    3. Wahoo Blue SC (BTLE)
    4. Polar H7 HRM (BTLE)

    We got to the Paired Devices screen where we were able to pair everything.  We could see her heart rate from the Polar H7, as well as her cadence and speed.  But once we started in-game, it wouldn't move or register any speed, just HR and cadence.

  • 1
    Avatar
    Scott B.

    Hey everyone - thanks to your feedback we've identified the bug pairing with BLE speed and cadence sensors. We're working on a fix which we plan to get out in the next game release. Stay tuned and thanks for your patience. 

  • 0
    Avatar
    James Allanson

    Any idea when the next release might happen?

  • 0
    Avatar
    Eric Fung

    I just gave this a try with the following equipment:

    Over ant+:

    Tacx vortex smart... mostly working except power sometimes drops to null as if no signal.

    Over Bluetooth:

    iphone4s - mobile link seems to run fine, and I can see the Bluetooth icon in the computer app.

    Fitbit Surge - not detected. Unsure if this is BLE compatible or if this device is locked to Fitbit's own app.

     

  • 1
    Avatar
    L Barker

    Hi,

    Thanks for rolling this out!

    It worked the first time I tried it out.  However all future sessions I'm unable to sync/see my equipment.   I started with just trying out the HRM.

    I'm runnnig

    1) OS X El Captian 10.11.1

    2) Iphone 6s Plus on IOS 9.1

    3) Wahoo BlueHR

    Plus same as Eric, I have a fitbit I thought I would try and its not seen for HRM.   Not really expecting that part to work though as they are probably proprietary.

     

    Thanks!

     

  • 0
    Avatar
    Jason Graham

    Hi! I'm so excited to try this out!

    Unfortunately I have the same problem as above. However, I did have something different happen. I plugged my HDMI cable from my laptop to my TV and each time I tried to take a pedal stroke the game crashed. Tried it a few times with it still connected to the TV with the same behavior. After I pulled the cable and just used my computer it was stable, despite my speed not being detected... which you're working on.

    I'm running:

    1. OSX Yosemite 10.10.3

    2. iPhone 6 (latest iOS)

    3. Wahoo BlueHR

    4. Wahoo BlueSC

     

    Thanks!

  • 0
    Avatar
    Artur Bak - BMW Garage TT

    Hi,

    Yesterday I tried to test the BLE support of the Zwift.

    My configuration:
    - Elite Turbo Muin (not real)
    - MacBook Air (10.9.5)
    - IPhone 5s (OS 9.1)
    - Polar H7 (HRM) BLE
    - Polar CAD BLE
    - Polar SPD BLE

    On the phone I connected all the sensors but the software Zwift saw only CAD & SPD Sensor but I had only read the parameters of cadence sensor.

    During pedaling I stood in place without reading speed.

    I would be grateful for the launch of full integration with the BLE sensors.

    Thx

  • 0
    Avatar
    L Barker

    Further to my experience already posted.   I've tried the wahoo cadence/speed sensor and that works fine while at the same time the HRM can not be seen even though it did work the first time I tried it.

  • 3
    Avatar
    Bill Verdon

    FYI....I was able to get this to work for my Kurt Kinetic inRide (version 1) BLE POD using a borrowed iPhone.  Is it safe to assume that this will also work with KK's latest BLE POD (version 2)?

    Please get the Android version out soon!

     

    Thanks! 

  • 0
    Avatar
    Joe Royle

    Hi , Great news for the Ble BETA programme. 

    I am running macbook El Capitan, iPhone 6 and your instructions with same WIFI. The bluetooth item comes up and connects with my iPhone 6. Hwoever my Mio Alpha monitor is not detected and nor is my Schoche Cadence detector.

    I can see however through other apps that both these items are being detected by the phone but not my Swift ?

     

    Any help appreciated, i appreciate it is a BETA so hope this helps you guys

     

    Regards

     

    Joe

  • 1
    Avatar
    alan henderson

    Delighted to see the release of BLE beta ... managed to get it paired with my Kurt Kinetic inRide (789) pod / Win 7 PC and iPhone 6.  Not picking up the Kinetic HR monitor though, but will keep trying.

    Looking forward to playing with this over the next few days

    Cheers.

    Alan

  • 0
    Avatar
    Michael Henasey

    Tried BLEBETA and could not get Zwift to find my Polar H7 Bluetooth HRM.

    I could see that my iPhone was paired with it but still Zwift would not recognize it.

    If my computer supports BT 4.0, why can't Zwift just use that instead of using the phone as a man-in-the-middle? Sticking with ANT+. It works.

     

  • 0
    Avatar
    Y ohans

    I had a ride using the BLE Beta for pairing a Suunto Smart HRM together with all other sensors wired from the Computrainer. It worked well albeit a little kludgy given that my computer has Bluetooth 4

  • 0
    Avatar
    Frans Poldervaart

    When do you expect to update the Zwift software. I am running out of my test trial dates, 10 days left without a single KM :(

     

  • 0
    Avatar
    Brian Gorby

    Hi Frans - the issue with Speed + Cadence over BLE in Zwift will be fixed in a new game update this week.

  • 3
    Avatar
    Bill Verdon

    Thanks for working on this! Currently I use TrainerRoad to calibrate my Kurt Kinetic inRide device. I also bought the pro flywheel (which adds 12 lbs) which I have to specify in order to calibrate the power. I am currently using the device relay function to relay this info via ANT + which works fine. I have tested the BLE functionality using a borrowed iPhone and that worked fine. I know yo guys are working on Android which is great. I have a few questions though.

    1) Will using a mobile device be the solution to bridge BLE to WiFi as a permanent one or will this be incorporated in the PC app somehow?

    2) Will you be adding a inRide specific calibration option (as TrainerRoad does) or will I have to perform this using my KK inRide app first each time I use zwift? The assumption being that the calibration of settings stays with the device and will be calibrated once connected to zwift. 

     

    Thanks

     

  • 0
    Avatar
    Eric C.

    Hi Frans,

    That shouldn't be happening - if you haven't ridden then the days should not be counting down. I'm going to figure out what's happening and make sure you get your full 2 weeks.

  • 0
    Avatar
    Manolis Kariotis C



    Hi,

    My system:

    windows 10 & osx El capitan

    Elite power mag cubo smart with misuro b+ bluetooth 

    sbs heart sport band bluetooth

    Iphone 5c

    The zwift connects with the iphone app but not finding any of the bluetooth devices

    Finaly it found my misuro Bluetooth. The cadence pairs and rpm seem right.

    The speed sensor + classic trainer also pairs but the speed is unbelievable 150 mph. And after a few meters it stops.

     Same in MAc and windows

     

  • 0
    Avatar
    Brian Gorby

    With the latest Zwift game release (1.0.8691), we've addressed the issue where a speed and cadence sensor paired over BLE would not move your rider in the game.

    If you've been experiencing this issue, please give it a try!

  • 0
    Avatar
    Syed Omar

    Hi Brian, I did a quick try just now and it works perfectly! It detects my speed/candence sensor and my player is moving.

    However, it couldn't find my bluetooth HRM. Its Coospo H6 HRM. Strava and other apps on my iPhone managed to find it, but it kept searching on Zwift and does not appear to be found.

    Thanks again for the fix, will deffo give this a spin tomorrow! I'm excited!

  • 0
    Avatar
    Y ohans

    BLE range is not as good as ANT+ imo.

    Had a 2nd ride with Suunto Smart HRM connected via iPhone. The start up process worked ok as before.

    Now during my rides I often need to get off the bike to refill water bottle, turn the fan on, use the bathroom, etc..

    I found that the connection dropped out a number of times during these movements away from the bike and iPhone and would not consistently reconnect. Out of 3 lost connections i was only able to get 1 to reconnect. Ended up getting ANT+ hrm for the rest of ride.

    FYI - iPhone needed to stay on charger as power use on Zwift is very high, so I was not able to just leave it in a pocket and carry it with me.

  • 0
    Avatar
    Kerry Hoeschen

    I have a kinetic fluid road machine 2700 with InRide, iPhone 6, and laptop with Windows 10 (or MacBook Air). I enabled Bluetooth on the iPhone app. When I ride, the Kinetic app picks it all up but nothing seems to be talking to the Zwift app. Nothing is recorded. No image of riders. Ideas?  

  • 0
    Avatar
    Brian Gorby

    Hi Yo - thanks for the feedback. We're working on better handling of dropped connections, and improving battery usage.

     

    Hi Kerry - were your devices connected to the Kinetic app before you attempted to pair with Zwift? BLE devices can only be connected to a single app at a time.

  • 0
    Avatar
    Kerry Hoeschen

    Yes. Will uninstalling the kinetic app do the trick?

Please sign in to leave a comment.