1

Resistance issue with Elite Drivo

Hello,

I use an Elite Drivo and I have an issue when I do races on Zwift, the resistance is too low when I ride on flat (0 %) and on descent. I must pedal at about 130/140 rpm with the 53/11 gear when I ride on flat when someone speed up, and I have an average of 105/110 rpm on the entire race with the 53/11. So It's really hard to take a relay or close gaps, I can't generate enough power with this resistance. So can I increase the resistance of the trainer with Zwift app or maybe Elite My E-Training app ?

Thank you.

Joffrey Degueurce.

16 comments

  • 0
    Avatar
    Eric Min

    Almost sounds like your trainer is not in "sim" mode. Make sure your trainer is not connected to any other software when on Zwift. Also, you should set the trainer difficulty slider scale in the settings screen in the middle. This will give you the best gearing range across different terrain. 

  • -1
    Avatar
    Jason K.

    Aside from what Eric mentioned, we currently also recommend using Elite trainers over ANT+ instead of Bluetooth for the better experience. While we support both, ANT+ FE-C is better right now, as it's standardized for third-party software. I see you have an ANT+ dongle, so try that instead.

  • 1
    Avatar
    Frankie Timmons CVR

    I am also having the same issue. I just wanted to say for informational sake that everything works perfectly on ANT+ and all the gradient changes on Bluetooth work great above 1-2% its just the resistance at or around zero at least for me just on Bluetooth releases to much and your spun out ... Thanks for addressing this and good luck Jofferey 

  • 0
    Avatar
    Gustavo Gomez

    I have the elite drivo using ant+ in my windows computer. No issues with resistance during the races. I have to set the trainer difficulty off to feel natural.

    Update:

    After using an USB extender cable next the trainer  transmitter, my problems are gone. I am setting the resistance to 70% now  No weird issues anymore  

  • 0
    Avatar
    Nicolas Chauvel KISS(B)

    Hi Lacy, I own a drivo too using ANT+ connection to my laptop. I noticed strange reactions on slopes changes, even when slopes variations are slight (let say + ou - 1%). If the slope decreases with 1% (from 9% to 8%) I feel like trainer ressitance becomes quite easy for a while. On the other hand, if slope increases with 1%, resistance becomes quite hard and doesn't reflect what it should be in real life. Trainer reacts like it would over or under compensate slopes changes.

    have you noticed this and what does setting off trainer difficulty changed for you?

    Thanks for helping

     

  • 0
    Avatar
    Gustavo Gomez

    After using an USB extender cable next the trainer transmitter, my problems are gone. I am setting the resistance to 70% now No weird issues anymore.
    Are you using an USB extender cable?

  • 0
    Avatar
    Nicolas Chauvel KISS(B)

    Hi Lacy, thanks for your quick response, yes I do use an USB extension cable, I already used it with my old Tacx Genius that I replaced by the DRIVO. I set the resistance to 90%, as I felt the reaction of my DRIVO I did explain upper was more significant when resistance parameter was lower.... But I'm not sure and I have to check this out.

    Haven't you noticed what I described on slopes changes in my previous post?

  • 0
    Avatar
    Gustavo Gomez

    I had slope resistance problems when I was having connection issues.

    Have you run Zwift analyzer on your riding logs? My USB cable is less than one foot away from the drivo light indicators for a strong signal.

  • 1
    Avatar
    Torgeir Hasaas

    Same issue here with my new Drivo. Resistance om flat ground is allmost non-existant and when hitting the slopes the resistance becomes unbearable, to the point where I have to shift gears. Allmost like the trainer difficulty has changed, but it hasnt. 

    This is with Bluetooth, and altough it might work with ANT+, I would really like this to work via Bluetooth as this is the way I prefer to Zwift (My iPad is much faster to set up for a ride than my computer, essential for people with a tight schedule)

    So, a fix for this would be highly appreciated.

  • 0
    Avatar
    Torgeir Hasaas

    Any news on this? Elite claims this is an error on Zwift's part of the software, ref http://forum.elite-it.com/viewtopic.php?f=20&t=835

  • 0
    Avatar
    Harold Heyermans

    If you want to run bluetooth try using a "Cable" adapator it is for adding ant+ to Apple products. I am using Apple TV with no issues and have trainer difficulty set aprox 40%. 

    http://store.npe-inc.com/cable-connect-ant-to-ble/

  • 0
    Avatar
    Gustavo Gomez

    I have used zwift every day for the last four months. Working great with ant+. No problems. If you are using Bluetooth, get ant+. I have a friend with a Mac using Bluetooth with a hammer and he had to switch to ant+ because of resistance issues.

  • 1
    Avatar
    Torgeir Hasaas

    I dont want to use ANT+, as it is more cumbersome to rig my computer, powersupply and ant+ dongle vs just connecting to my iPad. Bluetooth worked fine with my Kickr Snap, so the problem is with the Drivo one way or the other.

    The Drivo boasts both ANT+ and Bluetooth support, and so does Zwift, so why should one be limited to one of them? 

    I suspect the CABLE solution might not work, as it still sends the data via Bluetooth, which is the problem. The data my iPad recieves from the Drivo is correct (the wattage) however the Drivo fails to ramp up the resistance when giving a lot of power on the flats.

  • 1
    Avatar
    Gustavo Gomez

    It is still a Zwift problem. You can wait for Zwift to fix it.

    Zwift is not properly implementing the controls in Bluetooth mode not only for the drivo but for other trainers as well.

     

  • 0
    Avatar
    Eric Gray

    Add me to this list.  I’ve been using my Drivo for almost two years on Zwift using ant+ to control it.  I’ve had to move my iMac to our office and have to now use my iPad for Zwift.  Before anyone says anything, no I cannot move my pain cave up to the office...so I need to use the iPad.

    First ride was this morning and it didn’t go so well.  Even with putting trainer difficulty all the way up to 100% any time I was on a 0% or negative grade it was just rediculously easy as far as resistance goes.  Spinning out at well over 100 RPM after a sprint etc.  This is even with shifting to my smallest gear in the back.  On inclines it had some resistance, but not nearly enough to warrant shifting to a larger gear...just kept it on the 11 tooth gear and kept riding.  

    Im seeing people reporting that this is a known Zwift issue with Elite trainers for some reason.  Does anyone know if these same problems exist with Kickr Snaps as well?  If needed I suppose I could just start using my wife’s Kickr Snap until Zwift gets this figured out.  

  • 0
    Avatar
    Eric Gray

    I’ll go ahead and answer my own question about the Kickr Snap. Yes, it works via Bluetooth as it’s supposed to concerning the resistance felt in game. I did a ride this morning using my wife’s Kickr Snap and didn’t have to ride the 11 tooth cog on my cassette the whole time.

    So it looks like Zwift needs to figure out how to control the Drivo via Bluetooth so it acts more like how it’s controlled via ant+. Unfortunately I cannot ride the Drivo using my iPad like this, and my wife doesn’t want to use the Drivo either....so I’m forced to move my iMac back down to the pain cave until Zwift can get it figured out. :(

Please sign in to leave a comment.