1

Drag/Resistance too low

Hi all, maybe someone can help - I use an Elite Drivo and Drag/Resistance is too low - at 50/34 and 11-25 I can't get to 500W in the flat below 150rpm- so racing makes no sense. Weight is setup correctly - any ideas?

11 comments

  • 0
    Avatar
    Lars Orth

    Hi. I have the same issue. Same Trainer and same crank set.

    Just looked at this and appears others have the same issue on different trainers.
    Sounds like there ought to be a setting in Zwift to move the whole power range, so that 0% gradient has more resistance

  • 0
    Avatar
    Gerrie Delport TeamZF

     

    Just a shot in the dark.

    Have you tried to change the Trainer Difficulty?

    You can read more about it here: http://zwiftblog.com/using-the-trainer-difficulty-setting-in-zwift/

     

  • 0
    Avatar
    Lars Orth

    I think the trainer difficulty only impacts how steep a climb is/feels.
    So at 0% it would not change.

    That is my experience anyway.

  • 0
    Avatar
    Douglas Young

    Is this by any chance via bluetooth connection? My rampa does exactly the same thing. Fine over ant+

  • 0
    Avatar
    Jesper Madsen

    I had same problem on a RealAxiom (Elite) - there is a set of programs where you can calibrate the trainer you have. Look at the Elite website, or send an email to Elite support. Of course, you can only do this if you can borrow a powermeter to validate your calibration.

  • 0
    Avatar
    vyns edwards

    same as stefan really , chewing the bars to get any decent power , got in touch with elite and they said the turbo muin b+ i had before (which was great ) was designed with high resistance even on low carance whereas the drivo (which i have now) is designed to replicate true riding outside . which it doesnt . elite customer service a bit crap considering that the drivo wasnt that cheap ,feeling annoyed

  • 0
    Avatar
    Stefan Seebauer ZHR (C)

    Hi Zwift Team,

    coming back to you - the issue is different on different platforms/protocols. It's worst on iOS combined with Bluetooth - strange: during a race it worked for one lap, then resistance dropped - it's like the program didn't realize changing from 53 to 39 and back anymore.

    With ANT+ on Windows it seems to run nicely - but the setup with an iPad on the handlebar is so much better (don't want to buy an ANT+ dongle)...any idea? Is your team working on it?

     

    Regards

    Stefan

  • 0
    Avatar
    Gary McDonald

    Hi, Just got a Elite Direto and I too am struggling to get enough resistance on a flat or limited gradient course, I'm spinning at 100 rpm+ to get even 220W. I have not adjusted the difficulty yet but from what I've read it seems to be just for the climbs and descents? Anyone have experience with this?

     

    Gazza

  • 0
    Avatar
    Torgeir Hasaas

    This seems to be a common problem with elite trainers as there is several threads regarding this issue. I experience the same thing with my new Drivo, very annoying.

  • 0
    Avatar
    Eric Gray

    Same here with my Drivo.  Ant+ works fine but connecting via Bluetooth results in very low resistance as compared to ant+. 

  • 0
    Avatar
    Serhiy Tymoshenko

    Same on Elite Rampa. But 1.5 years back i've experienced no problems with my Rampa, it just have started few month ago...

Please sign in to leave a comment.