Zwift - Indoor Cycling. Outdone.
Submit a request
You need to sign in to view this page.

Some BLE Devices can't pair over Android ZML

Update

We deployed a potential fix for this issue with Android Zwift Mobile Link ver 1.8.2. If you are affected by this, please submit a ticket with your game logs (all the files in your Documents\Zwift\Logs folder) and the brand/model of your mobile device.

Issue

We're currently investigating an issue that's preventing some sensors from pairing as both Power and Controllable Trainer through Zwift Mobile Link BLE. We haven't found a common thread tying all the reported cases together, and this seems to affect a variety of devices and OS's.

Reported devices include the following:

  • Galaxy S3
  • Galaxy S5
  • Galaxy S6
  • Galaxy S7
  • MOTOROLA MOTO G XT1032
  • Sony Xperia XZ
  • Sony Xperia Z2

Workaround

While we work to resolve this issue, you may still be able to at least pair just Power via BLE. While you won't be able to get resistance, you'll still be able to ride.

Alternatively, depending on what platform you're using, you can use one of these methods instead.

  1. If you're on Mac, you can use native BLE to connect instead of the Mobile Link app.
  2. If you're on Mac or PC and have an ANT+ dongle, you can connect through that protocol instead.
  3. If you have an iOS device, you pair directly with your iOS device, so this shouldn't be an issue.
  4. If you have an iOS device and plan to ride on your PC/Mac, you should be able to use the iOS Mobile Link app instead of the Android Mobile Link app to bridge your connections without problem.

 Thanks for your patience and understanding!

Have more questions? Submit a request

0 Comments

Article is closed for comments.